Loading and Saving Pictures

Photo Sieve can load common picture file types such as bmp, gif, ico, icns, jpg, png, tga, and tif. When saving, Photo Sieve automatically converts other picture file types to jpg as only jpg files can contain the text, tags, and other information added by Photo Sieve.

Loading pictures adds to the pictures already loaded. If you want to start over, use menu "Select/Select None" and then "Select/Remove Unselected" to remove all the pictures currently loaded. In most cases it will be easier to work with 50 - 300 pictures at a time. Photo Sieve may run slower as you add more pictures and you'll have more trouble locating pictures.

Menu "Select/Remove Unselected" only removes the unselected pictures from memory, freeing up space to load more pictures. All your pictures are still on your computer.

The status bar at the bottom of the screen shows how many pictures you loaded.

Menu "File/Save Album"

Saves all loaded pictures as an album. A "Picture Album" file has a file type of "psiv" and includes filenames, the tag column order, and all tag columns appearing in the "Tags" tab of the lower "Overview" window. You can include the same picture in more than one album. The album file stores the picture's filename so each album loads the same jpg file. Any picture comments or tags added or edited in one album automatically appear when the same picture is loaded as part of a different album.

When you save an album to the same directory as the pictures, stored filenames are relative to the album's directory and are stored without the path. This simplifies moving or sharing albums.

If the pictures are in a higher level directory, or a different drive, the album stores the full file path.

Menu "File/Load Album"

Loads all pictures stored as an album. If these are the first pictures loaded, only the column tags stored in the album display in the "Tags" tab of the lower "Overview" window. If other pictures are already loaded, pictures from the album are added.

Sieve and load selected files from anywhere on your computer.

Menu "File/Save To"

Save selected files to a directory of your choice. Optionally create subdirecties from a selected custom tag. After saving, your selected pictures will all be in one place for easy uploading, emailing, or creating a zip file to share.